Лабораторный практикум

по дисциплине «Информатика»

Лабораторная работа № 1.

Операционная система MS Windows98.

Лабораторная работа № 2.

Стандартные приложения MS Windows.

Лабораторная работа № 3.

Основы работы с текстовым процессором MSWord.

Лабораторная работа № 4.

Решение некоторых математических задач с использованием табличного процессора MS Excel.

Лабораторная работа № 5.

Обработка информации с использованием СУБД MS Access.


Основы работы в текстовом процессоре MS Word.

Составители:

к.т.н. Уразбахтин Р.Н.,

Ямилова Л.Р.

Цель работы: Приобретение навыков создания и редактирования текстовых документов с использованием текстового процессора MS Word.

Контрольные вопросы.

1. Как можно настроить экран текстового процессора MS WORD.

2. Какие основные элементы содержит окно MS WORD.

3. Что отображается в строке состояния при указании на кнопку панели инструментов.

4. Как получить справку в текстовом процессоре MS WORD.

5. Для чего нужна в тестовом процессоре панель форматирования.

6. Что такое курсор.

7. Как можно выделить с помощью мыши вертикальный блок текста.

8. Какие операции можно выполнять над выделенным объектом.

9. Каким образом можно изменить регистр букв текста без повторного набора.

10. Чем отличаются операции копирования и перемещения текста.

11. Каким образом можно сохранить документ под другим именем.

12. Что означает форматирование символа, абзаца.

13. Как создать специальные текстовые эффекты с помощью WordArt.

14. Каким способом можно импортировать графику в текстовый документ.

15. Каким образом можно создать текст в качестве водяного знака.

Практические указания

[На главную страницу]


Решение некоторых математических задач с использованием

табличного процессора MS Excel

Составители:

к.т.н., доцент Ахметсафина Р.З.,

к.т.н., доцент Строкина Ю.Г.

Введение

Лабораторная работа №1

Построение графиков

Цель работы - научиться с помощью мастера диаграмм строить графики` для более наглядного представления данных.

Примеры решения задач.

Варианты заданий.

Лабораторная работа №2

Нахождение корней уравнения

Цель работы – научиться находить определенный результат для ячейки с помощью подбора значения другой ячейки на примере полиномов различных степеней.

Примеры решения задач.

Варианты заданий.

Лабораторная работа №3

Работа с массивами

Цель работы - научиться производить расчеты по формулам, зависящим от большого массива данных.

Примеры решения задач.

Варианты заданий.

Список литературы

1. Гарнаев А.Ю. Использование MS Excel и VBA в экономике и финансах. – СПб.: БХВ – Санкт-Петербург, 1999. – 336 с.

2. Microsoft Excel 2000: Справочник/Под ред. Б.Карпова. – 2-е изд. – СПб.: Питер, 2000.-512 с.

3. Рычков В. Самоучитель EXCEL 2000. – 2-е изд. – СПб.:Питер, 2000.-336 с.

[На главную страницу]


Лабораторная работа

Лабораторная работа №1

Построение графиков

Примеры решения задач

Пример 1

Рассмотрим процедуру построения графика функции

Y = cos 2 (p x) при x Î [0,1].

Для построения графика функции необходимо сначала построить таблицу ее значений при различных значениях аргумента, причем аргумент изменяется с фиксированным шагом. Будем считать, что шаг h = 0,1. Необходимо найти y(0), y(0,1), y(0,2),…, y(1). С этой целью в диапазон ячеек A1:A11 надо ввести значения переменной х 0, 0,1, 0,2 0,3 … 1. Отметим, что выбранные значения переменной образуют арифметическую прогрессию. Заполнение ячеек членами арифметической прогрессии в Excel можно осуществить двумя способами.

Первый способ. В ячейки А1 и А2 введите первый и второй члены арифметической прогрессии и выделите эти ячейки. После этого установите указатель мыши на маркере заполнения выделенного диапазона (рис. 1) и протащите его вниз до тех пор, пока не получится числовой ряд.

Рис. 1. Указатель мыши на маркере заполнения

Второй способ. В ячейку А1 введите первый член арифметической прогрессии. Выберите команду Правка, Заполнить, Прогрессия (Edit, Fill, Series) и в открывшемся диалоговом окне Прогрессия (Series) (рис. 2) в группе Расположение установите переключатель в положение По столбцам, а в группе Тип – в положение Арифметическая. В поля Шаг и Предельные значения введите нужные значения.

Рис. 2. Диалоговое окно Прогрессия

Затем в ячейку B 1 введите формулу =COS(ПИ( )*А1)^2.

Ввод формул в ячейку можно производить с клавиатуры или с помощью диалогового окна Мастер функций, вызываемого командой Вставка, Функция (Insert, Function) или нажатием кнопки [image] панели инструментов Стандартная (Standard). Мастер функций содержит список всех встроенных в Excel функций, а также справки по синтаксису функций и примеры их применения. Отметим, что при использовании мастера функций перед вводом формулы в ячейку не надо вводить знак “=”, так как мастер функций введет его сам.

Для того чтобы завершить процесс табулирования функции, выделите ячейку B 1, установите указатель мыши на маркере заполнения и протащите его вниз до ячейки B 11.

Для построения графика функций вызовите мастер диаграмм с помощью команды Вставка, Диаграмма (Insert, Chart) или нажатием кнопки [image] на панели инструментов Стандартная (Standard).

На первом шаге мастера диаграмм выберите тип диаграммы - График и вид графика.

На втором шаге введите диапазон ячеек B1:B11, по которому будет строиться график и установите переключатель Ряды в положение В столбцах.
Рис. 3. Диалоговое окно Исходные данные

Выберите вкладку Ряд (рис. 3) и в открывшемся диалоговом окне Источник данных диаграммы в поле Подписи по оси X введите диапазон А1:А11.

На третьем шаге мастера диаграмм в окне Параметры диаграммы, выбирая нужные вкладки, введите название диаграммы, подписи по оси X и Y, добавьте легенду и т.д (рис. 4).

Рис. 4. Параметры диаграммы

На четвертом шаге мастера диаграмм укажите, где будет размещен график: на отдельном листе или на имеющемся.

Нажмите кнопку Готово, график построен (рис. 5).
Рис 5. Результат построения графика функции

Пример 2

Рассмотрим пример построения графика функции

x Î [0,1].

Этот график строится так же, как и в примере 1, за одним исключением – в ячейку B 1 вводится формула:

=ЕСЛИ(A1<0,5; (1+ABS(0,2-A1))/((1+A1+A1^2); A1^(1/3)).

Варианты заданий

[На предыдущую страницу]


Лабораторная работа

Лабораторная работа №1

Построение графиков

Варианты заданий

Построить в разных системах координат графики следующих функций

Таблица 1

№ | Функция | Отрезок
1 | , |
2 | , |
3 | , |
4 | , |
5 | , |
6 | , |
Продолжение таблицы 1
7 | , |
8 | , |
9 | , |
10 | , |

Примеры решения задач.


Лабораторная работа

Лабораторная работа №2

Нахождение корней уравнения

Варианты заданий

Найти все корни уравнения

Таблица 2

№ | Уравнение
1 |
2 |
3 |
4 |
5 |
6 |
7 |
8 |
9 |
10 |

Примеры решения задач.


Лабораторная работа

Лабораторная работа №3

Работа с массивами

Примеры решения задач

Пример 1
В качестве первого примера простой операции над массивами рассмотрим умножение массива А1:В2 на число 5. Выделите на рабочем листе область, например, D 1:Е2, такого же размера, как и массив – множимое (рис. 9).

Рис. 9. Выделение диапазона для ввода результирующего массива
Теперь введите формулу =А1:В2*5.Для этого установите курсор в строке формул и закончите ввод не как обычно нажатием клавиши Enter, а нажатием клавиш Ctrl+Shift+Enter. Таким образом вы сообщите программе, что необходимо выполнить операцию над массивом. При этом Excel заключит формулу в строке формул в фигурные скобки (рис. 10): {=A1:B2*5}

Рис. 10. Произведение массива на число

При работе с массивами формула действует на все ячейки диапазона. Нельзя изменять отдельные ячейки в операндах формулы. Аналогично можно вычислить сумму (разность) массивов (рис. 11).
Рис.11. Сумма двух массивов

Аналогично можно определить массив, каждый элемент которого связан посредством некоторой функции с соответствующим элементом первоначального массива (рис. 12)
Рис. 12. Вычисление функции от каждого элемента массива

В Excel имеются специальные встроенные функции для работы с матрицами:

МОБР (MINVERSE) | Обратная матрица
МОПРЕД (MDETERM) | Определитель матрицы
МУМНОЖ (MMULT) | Матричное произведение двух матриц
ТРАНСП (TRANSPOSE) | Транспонированная матрица

Во всех случаях при работе с матрицами перед вводом формулы надо выделить область на рабочем листе, куда будет выведен результат вычислений.

Решим в качестве примера систему линейных уравнений с двумя неизвестными, матрица коэффициентов которой записана в ячейки F 1:G 2, а свободные члены – в ячейки I 1:I 2 (рис. 13). Для решения этой задачи вспомним, что решение линейной системы АХ=В, где А – матрица коэффициентов, В – столбец (вектор) свободных членов, Х – столбец (вектор) неизвестных, имеет вид Х=А-1В, где А-1 – матрица, обратная по отношению к А. Поэтому для решения нашей системы уравнений выделим под вектор решений диапазон К1:К2 и введем в него формулу, как показано на рис. 13.

Рис. 13. Решение системы линейных уравнений

Решим также систему линейных уравнений А2Х=В, где

Для решения этой системы введем в диапазон ячеек А1:В2 элементы матрицы А, а в диапазон ячейки D 1:D 2 – элементы столбца свободных членов В. Выберем диапазон F 1:F 2, куда поместим элементы вектора решения, и введем следующую формулу:

{=МУМНОЖ(МОБР(МУМНОЖ(А1:В2;А1:В2));D 1:D 2)}

Рассмотрим пример вычисления квадратичной формулы z=XTAX, где А – квадратная матрица, введенная в диапазон А1:В2, Х – вектор, введенный в диапазон D 1:D 2, а символ (Т) обозначает операцию транспонирования. Для вычисления z введем в ячейку F 1 (рис. 14) формулу:

{=МУМНОЖ(МУМНОЖ(ТРАНСП(D 1:D 2);A 1:B 2);D 1:D 2)}

Рис. 14. Нахождение квадратичной формы

Хотя результатом этой формулы является число, не забудьте для ее ввода нажать клавиши Ctrl+Shift+Enter. Если этого не сделать, в ячейке F1 появится сообщение #ЗНАЧ!
Вычислим теперь значение квадратичной формы z=YTATAY, где

Для решения этой задачи введем в диапазон ячеек А1:В2 элементы матрицы А, а в диапазон D 1:D 2 – элементы столбца Y. Для вычисления квадратичной формы введем в ячейку F 1 формулу:

{=МУМНОЖ(ТРАНСП(D 1:D 2);МУМНОЖ(ТРАНСП(А1:В2);МУМНОЖ(А1:В2;D 1:D 2)))}.

Пример 2

В качестве следующего примера работы с массивами рассмотрим решение системы линейных уравнений методом Гаусса. На рис. 15 приведены результаты решения методом Гаусса следующей системы линейных уравнений:

2х1+3х2+7х3+6х4=1,

3х1+5х2+3х3+х4 =3,

5х1+3х2+х3+3х4 =4,

3х1+3х2+х3+6х4 =5.

Рис. 15. Пошаговое решение системы линейных уравнений методом Гаусса

В диапазоны ячеек А33:D 36 и Е33:Е36 введены матрица коэффициентов и столбец свободных членов, соответственно. Содержимое ячеек А33:Е33 скопировано в ячейки А38:Е38, А43:Е43 и А48:Е48. В диапазон ячеек А39:Е39 введена формула:

{=A34:E34-$A$33:$E$33*(A34/$A$33)},

обращающая в нуль коэффициент при х1 во втором уравнении системы. Выделим диапазон А39:Е39 и протащим маркер выполнения этого диапазона так, чтобы выполнить диапазон А39:Е41. Это обратит в нуль коэффициент при х1 в третьем и четвертом уравнениях системы. Скопируем значения из диапазона ячеек А39:Е39 в диапазоны А44:Е44 и А49:Е49. Для копирования значений без формул воспользуйтесь командой Правка, Специальная вставка (Edit, Special Paste) и в открывшемся диалоговом окне Специальная вставка (Special Paste) в группе Вставить (Paste) установите переключатель в положение Значение (Value) (рис. 16).

Рис. 16. Диалоговое окно Специальная вставка

В диапазон ячеек А45:Е45 вводим формулу:

{=A 40:E 40-$A$39:$E$39*(B 40/$B$39)}.

Выделим диапазон А45:Е45 и протащим маркер заполнения этого диапазона так, чтобы заполнить диапазон А45:Е46. Это обратит в нуль коэффициент при х2 в третьем и четвертом уравнениях системы. Копируем значения из диапазона ячеек А45:Е45 в диапазон А50:Е50. В диапазон ячеек А51:Е51 вводим формулу

{=A 46:E 46-$A$45:$E$45*(C 46/$C$45)},

которая обращает в нуль коэффициент при х3 четвертого уравнения системы. Прямая прогонка метода Гаусса завершена. Обратная прогонка заключается в вводе в диапазоны G 36:К36, G 35:K 35, G 34:K 34 и G 33:K 33, соответственно, следующих формул:

{=A51:E51/D51}

{=(A50:E50-G36:K36*D50)/C50}

{=(A49:E49-G36:K36*D49-G35:K35*C49)/B49}

{=(A48:E48-G36:K36*D48-G35:K35*C48-G34:K34*B48)/A48}

В диапазоне ячеек К33:К36 получено решение системы.

Варианты заданий


Лабораторная работа

Лабораторная работа №3

Работа с массивами

Варианты заданий

1.
Решить системы линейных уравнений АХ=В, А3Х=В и вычислить значение квадратичной формы z =YTATA2Y, где

2.

Решить системы линейных уравнений АХ=В, А2АТХ=В и вычислить значение квадратичной формы z =YTA3Y, где

3.
Решить системы линейных уравнений АХ=В, ААТАХ=В и вычислить значение квадратичной формы z =YTATA3Y, где

4.

Решить системы линейных уравнений АХ=В, А2АТАХ=В и вычислить значение квадратичной формы z =YTATAATY, где

5.

Решить системы линейных уравнений АХ=В, ААТА2Х=В и вычислить значение квадратичной формы z =YTA3ATY, где

6.
Решить системы линейных уравнений АХ=В, А3АТХ=В и вычислить значение квадратичной формы z =YTA2ATAY, где

7. Решить системы линейных уравнений АХ=В, АТА3Х=В и вычислить значе
ние квадратичной формы z =YTAATA2Y, где

8.
Решить системы линейных уравнений АХ=В, ААТА2Х=В и вычислить значение квадратичной формы z =YTA2ATAY, где

9.
Решить системы линейных уравнений АХ=В, АТААТХ=В и вычислить значение квадратичной формы z =YTAATAATY, где

10.
Решить системы линейных уравнений АХ=В, А2АТАХ=В и вычислить значение квадратичной формы z =YTAATAATY, где

Примеры решения задач.


Е

Е. В. Брызгалов, А. П. Шестаков,

Пермский государственный педагогический университет

Практическая часть

Занятие 1. Создание базы данных. Ввод и форматирование данных.

1. Загрузите систему Windows. Загрузите СУБД Access. Появятся выплывающие карточки-подсказки. Сверните их. Если вам понадобится подсказка, то в любой момент вы можете вызвать карточки из меню Справка или с помощью соответствующей кнопки на панели инструментов.

Сначала нужно создать новую базу данных.

2. В меню Файл выберите команду Создать. Введите имя файла skaz.mdb и щелкните на кнопке ОК. Появится диалоговое окно База данных.

3. Внимательно прочитайте назначение кнопок на панели инструментов, медленно перемещая по ним указатель мыши.

4. Для создания таблицы выполните: Таблица, Создать, Новая таблица. Создание таблицы, то есть определение входящих в нее полей, производится путем заполнения специальной таблицы:

Поле | Тип данных | Описание

5. Внесите в специальную таблицу следующие данные:

Поле | Тип данных | Описание
№ | Счетчик |
Персонаж | Текстовый |
Профессия | Текстовый |
Особые приметы | Текстовый |
Герой | Логический | Положительный или отрицательный герой

Поле «№» не обязательное, мы его вводим в качестве ключевого, так как любая таблица должна иметь ключ.

6. Созданную таблицу нужно сохранить, дав ей имя с помощью команды: Файл, Сохранить как. Дайте таблице имя «Персонаж» и. щелкните на кнопке ОК.

7. Введите информацию в таблицу, выполнив: Таблица, Персонаж, Открыть, и обычным образом введите данные, например такие:

№ | Персонаж | Профессия | Особые приметы | Герой
1 | Буратино | деревянный человечек | длинный нос | да
2 | Папа Карло | шарманщик |  | да
3 | Карабас Барабас | директор кукольного театра | длинная борода, достающая до пола | нет
4 | Лиса Алиса | мошенница | хромая на одну ногу | нет
5 | Кот Базилио | мошенник | слепой на оба глаза | нет
6 | Мальвина | артистка театра | девочка с голубыми волосами | да
7 | Дуремар | фармацевт | характерный запах тины | нет
8 | Тортилла | хранительница золотого ключика | черепаха | да

8. При помощи мыши выделите:

a. запись 5,

b. запись 3,

c. записки с 3 по 7. Отмените выделение. Выделите все записи. Отмените выделение. Выделите поле «Персонаж».

Выделите одновременно поля «Профессия», «Особые приметы» и «Герой». Отмените выделение. Выделите все поля. Отмените выделение.

9. Выделите запись 6 в поле «Особые приметы». Выделите записи с 4 по 6 в поле «Персонаж». Не отпуская кнопку мыши, выделите эти же записи в полях «Особые приметы» и «Герой».

Отмените выделение.

10. Выделите всю таблицу.

Отмените выделение.

11. Измените ширину каждого столбца так, чтобы она была минимальной, но был виден весь текст.

Это можно сделать при помощи мыши, раздвинув столбцы, или следующим образом: выделить нужный столбец, нажать правую кнопку мыши, в контекстном меню выбрать команду Ширина столбца, в открывшемся окне выбрать опцию По ширине данных.

12. Высоту строки можно изменить аналогичным образом с помощью мыши или команды Формат, Высота строки. Причем, достаточно отредактировать одну строку, высота остальных строк изменяется автоматически.

Любым способом измените высоту строки - сделайте ее равной 30.

13. Измените шрифт данных таблицы на Arial Cyr, размер шрифта на 14, установите полужирное начертание.

Изменить шрифт можно так: а) вывести указатель мыши за пределы таблицы, нажать правую кнопку мыши, в контекстном меню выбрать команду Шрифт; б) в меню Правка на панели инструментов выбрать команду Шрифт.

14. Измените шрифт текста на Times New Roman Cyr, размер шрифта - на 10.

15. Измените ширину столбца «Персонаж» на 20, а столбца «Особые приметы» - на 25.

Вы увидите, что текст в этих полях расположится в две строки.

16. Подгоните ширину столбцов так, чтобы текст вмещался полностью.

17. Выполните сортировку таблицы по полю «Персонаж» в порядке, обратном алфавитному.

Это можно сделать так: выделите поле «Персонаж» и щелкните на кнопке Сортировка по убыванию на панели инструментов.

18. Верните таблицу в исходное состояние.

19. Сохраните таблицу «Персонаж».

20. Закройте таблицу «Персонаж».

Занятие 2. Редактирование базы данных.

1. Откройте таблицу Персонаж и добавьте в конец таблицы следующие записи:

№ | Персонаж | Профессия | Особые приметы | Герой
1 | Артемон | Пудель | Очень умный пес | Да
2 | Трактирщик | Хозяин таверны «Три пескаря» | Жаден и скуп | Нет

Это можно сделать тремя способами:

· • передвинуть курсор в конец таблицы и ввести новые записи;

· • щелкнуть на кнопке Новая запись на панели инструментов;

· • выбрать команду Записи, Ввод данных.

2. Скопируйте первую запись на место шестой записи.

3. Удалите пятую запись.

4. Скопируйте первую запись в конец таблицы.

5. Измените профессию Дуремара на «продавец пиявок».

Это можно сделать так: а) выделить в поле «Профессия» запись, содержащую слово «фармацевт», удалить выделенное слово в буфер и с клавиатуры ввести словосочетание «продавец пиявок»; б) в меню Правка на панели инструментов выбрать команду Заменить. На экране появится диалоговое окно замены, в которое надо ввести формат замены.

6. Замените во всей таблице слово «Буратино» на слово «Пиноккио».

7. Удалите записи, значение которых в поле «Персонаж» равно «Пиноккио».

8. Вставьте перед записью 4 следующую запись:

№ | Персонаж | Профессия | Особые приметы | Герой
1 | Пьеро | Артист театра | Грустные глаза | Да

9. Удалите записи с 7 по 11.

10. Удалите поле «Профессия».

Это можно сделать с помощью мыши, соединив границы полей «Персонаж» и «Особые приметы» или с помощью команды Правка, Удалить поле.

11. Вставьте следующее поле в таблицу:

Поле | Тип данных | Описание
Дата | Числовой | Условная дата рождения (целое число)

Чтобы вставить новое поле в таблицу, нужно выбрать в окне базы данных вкладку Таблица, щелкнуть на кнопке Конструктор (вы перейдете из режима таблицы в режим конструктора). В открывшемся окне надо установить курсор на ту строку, перед которой вам необходимо вставить поле, щелкнуть на кнопке Вставить строку на панели инструментов и ввести нужные данные.

12. Заполните новое поле в каждой записи.

13. Во всей таблице замените слог «но» на слог «ни». Для этого в записи таблицы необходимо выделить слог «но». Затем надо выбрать команду Правка, Заменить, и ввести формат замены.

14. Замените в таблице все буквы «о» на букву «а», а буквы «а» замените на букву «о».

15. Замените на слог «ра» все буквосочетания, первая буква которых - любая буква русского алфавита, а вторая - буква «р». Это можно сделать следующим образом: в записи таблицы выделить необходимое буквосочетание, например, слог «ер». Затем выбрать команду Правка, Заменить и ввести формат замены: заменить ?р на РА».

Занятие 3. Поиск данных по условию.

Предлагаемое ниже задание можно выполнить различными способами.

Способ 1. Вы создаете запрос по каждому из вопросов, которые предлагаются в конце описания данного занятия, и сохраняете его в виде таблицы. Для создания запроса надо выполнить следующие действия: Запрос, Создать, Новый запрос, Таблица/запрос, Класс, Добавить, Закрыть. После этого следует ввести условия запроса.

Способ 2. Выполнить последовательность действий: Таблица, Класс, Открыть. Затем щелкнуть на кнопке Изменить фильтр на панели инструментов, и с помощью построителя выражений вывести условия запроса. Далее на панели инструментов окна запроса щелкнуть на кнопке Применить фильтр. В результате на экране появится динамический набор записей, удовлетворяющих введенному условию. Но при дальнейших манипуляциях этот набор не сохранится. Если вы хотите сохранить данный набор записей, то надо выполнить следующие действия:

Фильтр, Файл, Сохранить как запрос.

Способ 3.В режиме таблицы надо вывести указатель мыши за пределы таблицы и нажать правую кнопку мыши. В контекстном меню следует выбрать команду Изменить фильтр. Все остальные действия точно такие же, как в способе 2.

Для того чтобы ответить на все предлагаемые ниже вопросы, необходимо знать правила задания шаблонов и условных выражений. Приведем несколько примеров.

Примеры шаблонов

Смысл символа | Шаблон | Результат поиска
Вопросительный знак (?),обозначающий один любой символ | За?ор | Забор Затор
Звездочка (*), обозначающая любую группу символов | Д*нь | День Добрый день Длинная тень
Знак фунта (#), обозначающий любую цифру | #-й | 5-й
 |  | 8- й
Квадратные скобки [], обозначающие один символ из указанного набора | Иванов[аы] | Ивановы Иванова
Восклицательный знак (!) в сочетании с квадратными скобками, обозначающий символ не входящий в указанный набор | Иванов[!аы] | Иванову (но не Иванова» или «Ивановы»)

Примеры условных выражений

Условное выражение | Значение поля, по которому производится поиск записей
Саратов | Текст «Саратов»
Not Саратов | Не текст «Саратов»
In (Саратов, Томск, Уфа) | Текст «Саратов», «Томск» или «Уфа»
<М | Текст, начинающийся с букв «А» - «Л»
>=М | Текст, начинающийся с букв «М» - «Я»
100 | Число 100
<=20 | Число 20
Date() | Текущая дата
>=01.01.94 | Даты позднее 01.01.94
Beetween 01.01.93 AND 31.12.93 | Дата 1993 года
*02.* | Дата, у которой значение месяца — февраль
Null | Пустое значение
Is Not Null | He пустое значение
Like "Р*" | Текст, начинающийся с буквы «Р»

1. В базе данных skaz.mbd откройте новую таблицу «Класс» и внесите в нее следующие поля:

Поле | Тип данных | Описание
№ | Счетчик |
Фамилия | Текстовый |
Имя | Текстовый |
Дата | Числовой | Дата рождения
Пол (м) | Логический | Пол мужской
Улица | Текстовый |
Дом | Числовой |
Квартира | Числовой |
Класс | Числовой |
Группа | Текстовый | Группа здоровья по физкультуре
Хобби | Текстовый |
Глаза | Текстовый | Цвет глаз

2. Заполните таблицу «Класс» следующим образом:

№ | Фамилия | Имя | Дата | Пол (м) | Улица | Дом |  | Квартира | Класс |  | Группа | Хобби | Глаза
1 | Суханов | Сергей | 16.02.81 | Да | Чердынская |  | 23 | 74 | 10 | основная |  | тяжелая атлетика | зеленые
2 | Пирогов | Юрий | 5.12.83 | Да | Куйбыщева |  | 6 | 31 | 8 | основная |  | футбол | голубые
3 | Лебедева | Света | 16.06.85 | Нет | Пушкина |  | 37 | 65 | 6 | специальная |  | вязание | карие
4 | Голдобин | Сергей | 23.05.88 | Да | Леонова |  | 12 | 10 | 3 | основная |  | лыжи | голубые
5 | Ельшина | Наташа | 24.05.82 | Нет | Чердынская |  | 37 | 48 | 9 | специальная |  | чтение | серые
6 | Суханова | Наташа | 20.12.86 | Нет | Ленина |  | 12 | 22 | 5 | подготовит. |  | шитье | зеленые
7 | Петрова | Света | 18.04.82 | Нет | Пушкина |  | 37 | 3 | 9 | основная |  | лыжи | серые
8 | Горина | Оля | 20.12.84 | Нет | Свиязева |  | 66 | 99 | 7 | подготовит. |  | аэробика | карие
9 | Попов | Михаил | 7.07.87 | Да | Леонова |  | 72 | 6 | 4 | подготовит. |  |  | голубые
10 | Сергеев | Саша | 30.11.89 | Да | Куйбыщева |  | 3 | 31 | 2 | основная |  | каратэ | зеленые
11 | Павлова | Елена | 13.12.85 | Нет | Пушкина |  | 5 | 6 | 6 | основная |  | аэробика | карие
12 | Емельянова | Наташа | 25.05.81 | Нет | Попова |  | 40 | 47 | 10 | основная |  | шитье | зеленые
13 | Евдокимов | Михаил | 18.08.80 | Да | Чердынская |  | 3 | 40 | 7 | основная |  | футбол | зеленые
14 | Евсеева | Елена | 14.10.84 | Нет | Ленина |  | 14 | 82 | 9 | основная |  | лыжи | серые
15 | Суханова | Света | 29.07.80 | Нет | Куйбыщева |  | 37 | 32 | 11 | основная |  | аэробика | карие

Ответьте на следующие вопросы:

1. Кто учится в VIII классе? .

2. Кто родился в 1984 году?

3. Кто живет на улице Пушкина?

4. У кого номе дома меньше 50?

5. У кого мужские имена?

6. Кто родился весной?

7. У кого фамилия начинается на букву С7

8. Кто закончит школу в этом году?

9. 9. Кто не занимается тяжелой атлетикой?

10. У кого сегодня день рождения?

11. У кого номер квартиры меньше 12?

12. Кто не определил свое хобби?

13. Кто родился до 1.01.85?

14. Кто живет на улице Пушкина, Леонова или Свиязева?

15. У кого фамилия начинается с одной из букв «А» — «К»?

16. Кто является однофамильцем с Сухановым Сергем?

17. Кто увлекается аэробикой и лыжами?

18. Кто из мальчиков живет на улице Чердынской?

19. У кого имена начинаются на букву С, а фамилия — на букву П?

20. У кого карие глаза и этот человек не умеет вязать?

21. Кто учится в старших классах?

22. У кого из специальной физкультурной группы женское имя?

23. Кто не живет на улице Ленина и не занимается в подготовительной группе?

24. Кто из мальчиков с голубыми глазами занимается каратэ?

25. Кто учится в классе, номер которого кратен 3, и живет на улице Пушкина или Ленина?

26. Назвать учащихся с серыми глазами, которые учатся в классе с нечетным номером или число в дате их рождения больше 15.

27. У кого номер класса является простым числом или он учится в специальной группе и его имя начинается на букву «Н»?

28. Кто из основной группы не живет на улице Пушкина или Ленина?

29. Кто из девочек, родившихся в мае или в феврале номер дома больше 36?

30. У кого из основной физкультурной группы имя начинается на букву «С» или «М», но фамилия не начинается на букву «П»?

Занятие 4. Работа с помощью мастера.

1. Создайте в новом файле таблицу «Класс» с помощью мастера таблиц. Для этого выберите корешок Таблица и выполните следующие действия: Создать, Мастер. На экране появится окно мастера таблиц. Внимательно просмотрите примеры таблиц и полей, предлагаемых мастером.

2. Выберите поля, необходимые для нашей таблицы «Класс» (см. предыдущее занятие). Недостающие поля можно будет добавить с помощью конструктора таблиц.

3. Выполните все действия, которые вам предлагает сделать мастер.

4. Дайте новой таблице имя «Класс».

5. Заполните таблицу и ответьте на вопросы, которые были вам предложены на занятии 3.

6. С помощью мастера создайте запрос, по которому можно определить, какие из героев, сведения о которых содержатся в таблице «Персонаж», положительные.

7. С помощью мастера создайте запрос для определения отрицательных героев, сведения о которых находятся в таблице «Персонаж».

8. С помощью мастера самостоятельно создайте форму для таблицы «.Класс».

9. Создайте различные типы форм и дайте им различные имена.

10. С помощью мастера создайте отчет для таблицы «Класс». Попробуйте сделать различные виды отчетов.

Занятие 5. Работа со связанными таблицами.

1. Создадим базу данных, которая будет хранить результаты экзаменов студентов одной группы за один семестр. Можно обойтись и одной таблицей, в которую включить поля «Фамилия», «Имя», «Предмет», «Преподаватель», «Оценка». Но тогда очень много данных будет повторяться, так как каждый студент сдает несколько экзаменов, и каждый экзамен сдают многие студенты.

Поэтому создайте три таблицы «Студенты», «Предметы», «Оценки» и заполните их. В первых двух таблицах первое поле будет иметь тип счетчик, а остальные - текстовый тип. В третьей таблице первое поле будет иметь тип счетчик, а остальные - числовой тип.

Таблица «Студенты»:

Код студента | Фамилия | Имя
1 | Антонова | Марина
2 | Бирих | Яков
3 | Волкова | Константин
4 | Волошина | Светлана
5 | Кашина | Наталья
6 | Ленц | Алексей
7 | Матвеев | Роман
8 | Наумова | Татьяна
9 | Юдинцева | Оксана

Таблица «Предметы»:

Код предмета | Название | Преподаватель
1 | Программирование | Половина
2 | Психология | Семак
3 | Статистика | Полыгалова
4 | Информационные системы | Клигман

Таблица «Оценки»:

Код оценки | Код студента | Код предмета | Оценка
1 | 1 | 1 | 5

2. Щелкните на пиктограмме Схема данных. Вы увидите созданные нами таблицы и связи, которые создал Access. Он автоматически связал поля с одинаковыми именами и совместимыми типами. В других случаях это можно сделать вручную, с помощью мыши достаточно перетащить одно поле на другое.

3. Обратите внимание, что выставлять оценки неудобно. Чтобы выставить Волкову «отлично» по статистике, надо помнить коды студента и предмета. К счастью, Access может оперировать с кодами, а информацию выдавать в текстовой форме. Сделаем это для предметов.

Выберите в таблице «Оценки» поле «Код предмета» и укажите тип Мастер подстановок. В качестве таблицы источника данных выберите таблицу «Предметы» и поля «Код предмета» и «Название». Теперь в режиме таблицы будут видны названия предметов.

4. Сделайте то же самое для фамилий студентов. А теперь сделайте так, чтобы подстановка выполнялась из двух полей, то есть выводились фамилия и имя. Для этого выберите поле «Код студента», вкладку Подстановка, затем выберите Источник строк и щелкните на кнопке с многоточием справа. Откроется построитель запросов, работа с которым не отличается от работы с обычным запросом. Вместо поля «Фамилия» введите строку [Фамилия]&" "&[Имя]. Теперь будет видна и фамилия студента, и его имя.

5. Добавьте сведения еще о двух-трех студентах в таблицу «Студенты». Перейдите в таблицу «Оценки». Обратите внимание, что информация о добавленных студентах оказалась в конце списка. Чтобы упорядочить список по алфавиту, вызовите построитель запросов для поля «Код студента» и установите сортировку по возрастанию. Сделайте то же самое для поля «Код предмета».

6. Поле «Код оценки» нам (в отличие от Access) неинтересно. Выделите этот столбец в режиме таблицы и выберите команду Формат, Ширина столбца. Установите ширину столбца равной нулю. Этого же результата можно добиться перетаскиванием правой границы столбца к левой.

7. Обратите внимание, что Access позволяет хранить несколько записей о сдаче одним и тем же студентом одного и того же предмета. Сделаем так, чтобы набор «студент-предмет» стал уникальным. Для этого в режиме конструктора установим для этих полей опцию ключевое поле. Это можно сделать с помощью меню Правка или панели инструментов.

8. Измените названия полей «Код студента» и «Код предмета». Для этого выберите строку Подпись на вкладке Общие. Теперь таблица «Оценки» будет выглядеть так:

Студент | Предмет | Оценка
Антонова Марина | Информационные системы | 5
Бирих Яков | Информационные системы | 4
Волков Константин | Информационные системы | 5
Волошина Светлана | Информационные системы | 5
Антонова Марина | Психология | 5
Бирих Яков | Психология | 5
Волков Константин | Психология | 4
Волошина Светлана | Психология | 5

9. Сделайте так, чтобы в поле «Оценка» вместо цифр можно было записывать «отлично», «хорошо» и т. д. Для этого создайте отдельную таблицу и используйте Мастер подстановок. При создании таблицы учтите, что существует четыре обозначения оценки: 1 — «отлично», 2 — «хорошо», 3 —«удовлетворительно», 4 — «неудовлетворительно». Установите связь:

10. Заполните таблицу «Оценки».

11. Сохраните результаты работы в файле students.mdb.

Занятие 6. Дополнительные возможности Access.

1. Откройте базу данных students.mdb.

2. Для создания удобной формы для ввода информации «Студенты» вызовите мастер форм и задайте следующие поля:

из таблицы «Оценки» — «Предмет», «Оценка»;

из таблицы «Студенты» — «Фамилия», «Имя»;

из таблицы «Предметы» — «Преподаватель».

3. Выберите представление данных по студентам с использованием подчиненной формы.

4. Откройте подчиненную форму и примените сортировку по возрастанию для предметов.

5. Откройте форму «Студенты» в режиме конструктора. Выделите и удалите метку оценки (сверху от места внедрения подчиненной формы). Подгоните вручную размеры формы.

6. Обратите внимание на две навигационные панели внизу формы, одна из них позволяет просмотреть информацию по студентам, вторая по предметам. Создайте свою навигационную панель. Для этого перейдите в режим конструктора, вызовите панель элементов (воспользуйтесь кнопкой панели инструментов или меню Вид). Убедитесь, что включен режим мастеров (кнопка с изображением волшебной палочки утоплена). Выберите элемент Кнопка и поместите его внутрь формы, установите действие Первая запись, подберите картинку.

7. Создайте еще четыре кнопки - Предыдущая запись. Следующая запись, Последняя запись. Добавить запись.

8. Выделите все пять кнопок. Это можно сделать двумя способами:

· щелкните на всех кнопках, которые вы хотите выделить, по очереди, удерживая нажатой клавишу Shift;

· используйте «лассо»: нажмите кнопку мыши и, не отпуская ее, растяните рамку вокруг всех кнопок.

9. Установите выравнивание по нижнему краю и одинаковые интервалы между кнопками, а затем уменьшите интервалы до нуля (меню Формат).

10. Щелкните правой кнопкой мыши на квадрате в левом верхнем углу формы. Выберите свойства и установите поле номера записи равным Нет.

11. Сделайте то же самое для подчиненной формы.

12. Откройте готовую форму «Студенты».

13. Самостоятельно создайте форму, аналогичную экзаменационной ведомости: в ее верхней части должны быть расположены название предмета и фамилия преподавателя, а ниже – список студентов с оценками. Воспользуйтесь мастером , а для окончательной доработки – режимом конструктора.

14. Переименуйте две созданные формы, дав им имена «Зачетные книжки» и «Ведомости».

15. Создайте кнопки, которые позволяли бы переходить от одной формы к другой. Для этого выберите вкладку Макросы, команду Открыть форму и имя из предложенного списка (Ведомости). Создайте аналогичный макрос для формы «Зачетные книжки.

16. Откройте форму «Ведомости» в режиме конструктора и перетащите на нее с помощью мыши макрос, открывающий «Зачетные книжки». Если все сделано верно, кнопка будет создана автоматически. Для редактирования ее внешнего вида, щелкните правой кнопкой и выберите пункт Свойства.

17. Сделайте то же самое для другого макроса.

18. Создайте макрос, который открывает обе формы и назовите его Autoexec. Сохраните базу данных, закройте и заново откройте ее. Написанный макрос будет выполняться автоматически.

Занятие 7. Зачетное занятие

1. Создайте базу данных «Книжная энциклопедия», содержащую сведения о произведениях различных писателей. Учтите, что у одного автора может быть много произведений. Продумайте схему данных, создайте таблицы и заполните базу данных следующей информацией:

Автор | Название | Год издания | Художественное? | Издательство
Гамильтон Э. | Возвращение к звездам | 1992 | Да | Селена
Гамильтон Э. | Оружие извне | 1995 | Да | Армада
Уильямсон Д | Звездный легион | 1994 | Да | Армада
Шарф Д. | Основы HTML | 1997 | Нет | Питер
Сборник | Лучшие игры для IBM | 1994 | Нет | Питер
Сборник | Java: 1001 совет | 1998 | Нет | Попурри
Пономаренко С. | Adobe Photoshop 3.0 | 1995 | Нет | BHV
Пономаренко С. | Corel Draw 5.0 | 1995 | Нет | BHV
Сборник | Delphi 2 в примерах | 1996 | Нет | BHV

2. Добавьте по своему усмотрению еще несколько строк.

3. Выполните следующие задания (создайте запросы):

· Укажите все нехудожественные произведения, вышедшие после 1995 г.;

· Определите, сколько книг выпущено каждым издательством№

· Найдите середину временного интервала, в течение которого вышли книги, содержащие в заглавии слово «звезда», и однокоренные с ним слова.

4. Создайте простые формы для ввода фамилий авторов и издательств.

5. Создайте формы, которые позволяют просматривать информацию о книгах по авторам и издательствам, а также вводить данные по книгам. Используйте знания, полученные на прошлом занятии. Свяжите эти формы кнопками, вызывающими макросы.

6. Создайте специальную форму, на которой разместите кнопки, вызывающие остальные формы. Создайте макрос ее автозапуска и минимизируйте окно базы данных.

7. Закончите оформление приложения.


Лабораторный практикум

: по дисциплине «Информатика»

Лабораторная работа № 1.

Операционная система MS Windows98.

Лабораторная работа № 2.

Стандартные приложения MS Windows.

Лабораторная работа № 3.

Основы работы с текстовым процессором MSWord.

Лабораторная работа № 4.

Решение некоторых математических задач с использованием табличного процессора MS Excel.